Timescapes - Digital Timelapse Discussion
http://forum.timescapes.org/phpBB3/

[SOLVED] Problem with A4988/DRV8825 stalling NEMA 11 motor
http://forum.timescapes.org/phpBB3/viewtopic.php?f=24&t=13934
Page 1 of 1

Author:  Max Z [ Tue May 22, 2018 1:33 am ]
Post subject:  [SOLVED] Problem with A4988/DRV8825 stalling NEMA 11 motor

Hey guys,

I have "hacked" a RAMPS 1.4 on 24v to work with dragonframe.
For my focus motor I run a Nanotec NEMA 11 Motor ST2818 (https://en.nanotec.com/products/210-st2818s1006-b/) with a planetary gear.

All motors work fine, but this motor skips steps when accelerating, and I can't drive it further single steps, I stalls / jumps back and forth.
I run the motor with 0,4 Volts.
The stepping mode I would like to use is 1/16.

I tried every stepping mode, and also changed from the DRV8825 to the A4988 and also tried "playing" with the voltage in a reasonable way. No luck.

The weird part is:

I have another drive-control box running two BigEasyDrivers on 24v (running 1/16 stepping mode, with 0,4 V on the driver) and the motor works flawlessly in Dragonframe with the same settings.

I read something about micro-stepping problems of the drv8825 running on 24v when you have modes of 1/32 or smaller. But I think this can't be it, can it?
Any advice would highly appreciated.

Sorry if my description is not the best, if you need further info, please let me know :)

Thanks,
Max

Author:  Max Z [ Thu May 24, 2018 1:58 am ]
Post subject:  Re: [SOLVED] Problem with A4988/DRV8825 stalling NEMA 11 mot

Ok, I banged my head against this, and as always:

The solution (or mistake) is often much simpler:
The extension cable I made a an incorrectly soldered wire.

Fixed it, problem solved.
Ohboy ;)

See you guys!

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/