Timescapes - Digital Timelapse Discussion

Virtual Dub's Deshaker is taking forever to process
Page 1 of 1

Author:  tribal-warrior [ Tue Dec 29, 2015 7:11 pm ]
Post subject:  Virtual Dub's Deshaker is taking forever to process

Ive been waiting an insanely long time for Virtual Dub's Deshaker tool to complete it's job. And it's still going. The first pass was relatively quick. The second pass is taking forever. After two hours, I checked the progress and (if I'm reading this correctly) 9 frames out of 165 have been processed. I let it run overnight. 12 hours have now passed and it's till the same – "9 / 165". Something is seriously messed up. It must be something to do with the huge file size. It's 4608 x 3072. I'm not used to working with video files that large – and neither is my computer. It's a time lapse video – and I also used Virtual Dub to create this video (from all the individual full res photo files) and that didn't take all that long to render. Usually, when I create time lapse videos with Virtual Dub, I select 1280 x 720 or 1920 x 1080. However, this particular clip suffers from a lot of unwanted movement. So I think it would be wise to start off with a super high resolution video and then later drop it down to 1920 x 1080 with Sony Movie Studio so that I don't lose quality from the initial cropping. I did previously use VD's Deshaker with a 1920 x 1280 copy of this same video clip and that was relatively quick to process. Though I know that the quality would suffer if that copy was played on a big screen so I decided to do it again with a full resolution copy.

I'm tempted to abort Virtual Dub's rendering and start again. I don't suppose it's the compression (I'm using the Xvid codec btw) that's contributing to the extreme slowness? Obviously, the codec would make the finished video file smaller and more manageable but I'm wondering if the compression process makes the rendering much, much slower? There was also another huge time lapse video file I recently created with Virtual Dub (4519 x 2542) in which I didn't use any codec (though I didn't use the Deshaker tool either) and that was quick to process. Though if I go ahead and render this current video with no codec (with Virtual Dub's Deshaker tool) then dump it into Sony Movie Studio, SMS's codec may also lead to a super slow render that could go on and on for endless hours. A real dilemma.

Author:  tribal-warrior [ Wed Dec 30, 2015 8:19 am ]
Post subject:  Re: Virtual Dub's Deshaker is taking forever to process

I think the main problem is that the file is just too large for VD to handle. Ive just tried to 'deshake' this time lapse video again, this time using a smaller file size. But I have another kind of problem now. I can't start the second pass and save the file. It returns an error. Something about not being able to start the compression. Could it be an issue with the Xvid codec? I could try another codec within VD but I don't know which would be the best one/s for HD video. Here's the list of codecs that can be found in Virtual Dub – Cinepack Codec by Radius, Intel IYUV, Microsoft RLE, Microsoft Video 1 and Xvid MPEG4. I honestly wouldn't have a clue which one to use.

Author:  tribal-warrior [ Wed Dec 30, 2015 6:20 pm ]
Post subject:  Re: Virtual Dub's Deshaker is taking forever to process

I tried again today and still no success. It will not start the rendering process. I get this same message again: "Cannot start video compression. An unknown error occurred (may be corrupt data.) Error code 100."

Maybe I'll create yet another video from the stills with a different file size and put that through VD's Deshaker.

Edit: that didn't work (creating a video file with a different size.) I get the same error message.

Any idea what's going on?

Author:  chardie [ Sat Jan 02, 2016 6:03 am ]
Post subject:  Re: Virtual Dub's Deshaker is taking forever to process

have you tried using a smaller file or making a standard avi to work out if its the codec ? if its the codec reinstall the codec and or virtual dub as a last resort perhaps
some codecs like a certain size or aspect ratio or else they wont work.is there any chance you have changed something ? i know sometimes i can crash vd when i add a filter
with some codecs when i have been experimenting. thats all i can think of
i have the xvid mpeg4 codec on my system it comes up with no known limitations when i click on it so in theory it shouldn't conflict with the deshaker. have you changed anything in the the configuration of the xvid codec ?
what happens if you leave the deshaker out ?
found this for you http://www.sheldonbrown.com/deshaker.html it may or may not help but i found it interesting

Author:  tribal-warrior [ Sat Jan 02, 2016 5:22 pm ]
Post subject:  Re: Virtual Dub's Deshaker is taking forever to process

Chardie, like I mentioned before, it was a much smaller file size on the very first attempt and there were no issues at all. Even with the huge 4k + file size I had created for the second attempt, it looked like it was processing, even though it didn't finish. I generally use VD a lot to create time lapse clips from stills and usually in those instances, I don't use Deshaker or Xvid and I have no problems. Anyhow, the problem has now been fixed. It just started randomly working (after using lots of different file sizes that weren't hugely different from each other - all the same aspect ratio.)

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group